Tipps & Kurse

Excel: Datum-Funktionen und bedingte Formatierung

Excel: Datum-Funktionen und bedingte Formatierung

  1. Fügen Sie im Zellbereich A1:L1 die Zahlenreihe 1,2,.. bis 12 ein.
  2. Schreiben Sie in die Zelle A2 Januar hinein und erweitern Sie die Monats-Reige bis zum Dezember nach rechts also bis L2.
  3. Formatieren Sie die Zellen A2:L2 fett und mit Alle Rahmenlinien.
  4. Schreiben Sie in die Zelle M2 2008 hinein.
  5. Erstellen Sie in Zelle A3 eine Formel, welche mit dem Inhalt von Zelle M2 und mit dem Inhalt von Zelle A1 das Datum des ersten Januar des betreffenden Jahres ermittelt.
    Tipp: =DATUM($M$2;A1;1)
  6. Erstellen Sie in Zelle A4 eine Formel, welche das entsprechende Datum, also den zweiten Januar, mit Hilfe der Zelle A2 ermittelt.
    Tipp: =A3+1
  7. Formatieren Sie die Zellen A3:A4, sodass Samstage mit grauer und Sonntage mit roter Hintergrundfarbe dargestellt werden.
    Tipp: Menü Format > Bedingt Formatierung
    Regel 1: =WOCHENTAG(A3)=7, Format 1: graue Füllfarbe
    Regel 2: =WOCHENTAG(A3)=1, Format 2: rote Füllfarbe
  8. Kopieren Sie die Formel aus A3 in den Zellbereich B3:L3.
  9. Kopieren Sie die Formel aus A4 in den Zellbereich B4:L4.
  10. Ziehen Sie in allen Spalten, jeweils die Formel in Zeile 4, bis zum letzten Tag des Monats hinunter.
  11. Damit es bei Nicht-Schaltjahren keine Probleme gibt, fügen Sie in Zelle B31 eine entsprechende wenn-Funktion ein: bei Schaltjahren soll das Datum angezeigt werden, bei Nicht-Schaltjahren soll nichts dargestellt werden.
    Tipp: =WENN(MONAT(B30+1)=2;B30+1;““)
  12. Formatieren Sie die Spalten A:L mit einer exakten Breite von 200 Pixel.
  13. Formatieren Sie die Zeilen 3:33 mit einer Zeilnehöhe von exakt 40 Pixel.
  14. Formatieren Sie den Zellbereich A3:L33, sodass die Inhalte in der Zelle links oben dargestellt werden.
  15. Formtieren Sie den Zellbereich A3:L33 mit schwarzen Rahmenlinien oben, unten, rechts, links und vertikal dazwischen.
  16. Benennen Sie denn Zellbereich A3:L33 mit Jahr.
  17. Benennen Sie denn Zellbereich A3:A33 mit Januar.
  18. Benennen Sie die anderen Zellbereiche unter den Monatsnamen jeweils entsprechend.
  19. Stellen Sie die Tabelle so ein, dass jeweils vier Monate auf hochgestellten Seiten gedruckt werden. Diese Zeile 1 soll nicht mitgedruckt werden.
  20. Vergleichen Sie Ihr Ergebnis mit folgender Beispiellösung 05-Kalender-Beispielloesung.xls.